Archivos de Categoría: Linux

[FIX] NS_ERROR_NET_INADEQUATE_SECURITY en Firefox 48

Actualice firefox a su mas reciente versión (Mozilla Firefox 48.0) en mi máquina con linux debian, inmediatamente no fue posible acceder a las mayoría de los sitios mas comunes, entiéndase google, yahoo, facebook

Da un error de NS_ERROR_NET_INADEQUATE_SECURITY cuando visito la mayoría de los sitios como Google o incluso mozzila.org  (support.mozzila.org si funciona)

Este mensaje parece estar asociado con los sitios que están utilizando el protocolo HTTP 2 / (recientemente soportado en Firefox), pero no se fijo un nivel de seguridad adecuado para ese protocolo.Así que una opción sería la de decirle a Firefox que NO utilice http 2, de modo que los sitios usaran de nuevo http 1.1.

Solución temporal y actual, espero que en la siguiente y esperada versión de firefox solución este bug

Procedimiento
============

  1. about:config en la barra de direcciones y pulse Enter. Haga clic en el botón de la promesa de tener cuidado.aboutconfacepta
  2. En el cuadro de búsqueda arriba de la lista, escriba SPD estamos buscando el valor network.http.spdy.enabled.http2
  3. Doble clic en network.http.spdy.enabled.http2 para cambiar el valor de verdadero a falso

spdyafalso

Reinicia y esta solución temporal funciona, evidentemente en la siguiente versión hacer lo mismo pero volviendo a poner el valor en true/verdadero

Mi recomendación es no usar esta versión de firefox al menos en linux (firefox 48), 

 

Despidiéndome de Copy.com

Resulta que muchos servicios de guardado-almacenamiento en la nube de archivos han ido menguando sus operaciones, ya sea limitando características, mermando el espacio disponible o sencillamente dejando de prestar sus  servicios

Un servicio con el que me encontraba muy contento era copy de copy.com que desgraciadamente deja de funcionar en un mes y me deja en el predicamento de buscar un nueo sitio que me de las funciones que necesito

copyfin

En estos momento ando probando pCloud,que al menos ofrece lo menos que necesito, y es que el poblema como usuario linux es que requiero no solo el espacio en la nube de mas de 7 gb, necesito que tenga programa en android y también y, muy importante, un programa en linux para que sincronice automáticamente la carpeta con los archivos que vaya modificando

Lo que mas me afecta es la carencia del programa de escritorio en linux en varios servicios de almacenamiento en la nube, y aunque el de pCloud es extremadamente básico y solo tienen versión para ubuntu-debian (mi otra pc la tengo en Arch), pues al menos salgo al paso en lo que mas uso

estoy de plano animándome a instalar ownclud aunque sea en casa pero si estoy en la misma red pues prefiero el rsync como estoy usándolo actualmente (de mi pc arch a lap debian)

En fin, en este momento buscando esa aplicación que tenga un programa de escritorio que funcione bien en linux, que sirva perfectamente en android, no es mucho pedir

  • uso dropbox pero se me queda corto el espacio, por lo que de plano lo deje para guardar las fotografías que tomo del celular
  • pCloud en pruebas me esta funcionando adecuadamente

Para obtener una cuenta de Dropbox
Para obtener una cuenta de pCloud

pantallazo de mi escritorio 2015

hace 2 años que no pongo nada de como luce mi escritorio, hoy pongo algunas capturas

prácticamente no lo he movido en el año, kde5 plasma con brisa oscuro

mi escritoro diciembre 2015Captura de pantalla_2015-11-09_23-50-12

mi escritorio 2015mi escritorio dic 2015

escitorio 2015escritorio 2015

luego subo las fotos de mi escritorio en entorno xfce4, que son los dos que utilizo

solución a medias: cups Unable to get list of printer drivers

Meramente no es una solución, solo una identificación del responsable, del paquete conflictivo y evidentemente si no es de uso diario, puede ser una solución eliminarlo.

el error sale en cups al agregar o intentar agregar una impresora

Unable to get list of printer drivers
sucess

Como uso arch, el primer lugar que consulte para arreglarlo fue el propio wiki https://wiki.archlinux.org/index.php/CUPS donde acotan

Note:

hplip depends on foomatic-db-engine which prevents the drivers list from appearing when a printer is added to CUPS via the web user interface (following error : “Unable to get list of printer drivers”). Possible workarounds:

Either: Install hplip first, then retrieve the PPD file that matches your printer from /usr/share/ppd/HP/. Next, remove hplip entirely as well as any unnecessary dependencies. Finally, install the printer manually using the CUPS web UI, selecting the PPD file you retrieved, and then re-install hplip. After a reboot, you should have a fully working printer.
Or: Remove hplip, foomatic-db and foomatic-db-engine along with any unnecessary dependencies. Reinstall hplip and restart CUPS. Install your printer using the CUPS web UI, which should now be able to find the drivers automatically. No reboot needed.

osea, responsabilizan a foomatic y piden que lo elimines… pues no es cierto, el responsable es gutenprint

para que desaparezca el error, en arch lo único que hice fue eliminarlo


#pacman -Rs gutenprint
#systemctl restart org.cups.cupsd

Para mi es indispensable foomatic, ya que mis impresoras son hp, y gutenprint solo lo utilizo desde gimp (raramente), y todo funciona bien sin gutenprint instalado. Viendo el error en internet le echan la culpa a hlip, a todo los paquetes de foomatic, y por lo mismo, casi todas las recomendaciones son desisntalarlos… el error lo crea gutenprint y ya le mande una nota a sus desarrolladores (por favor, insistan) para que lo arreglen.

si quieren probar la solución falsa, pueden darle

#pacman -R foomatic-db foomatic-db-engine foomatic-filters hplip

y dejar solo a gutenprint, que es lo que encontré en la mayoría de las páginas que consulté

insisto, el conflicto lo crea gutenprint, al momento de escribir esto instalada la versión gutenprint-5.2.10-1 de arch, el error me apareció al actualizar e impide ver la lista de impresoras

Disponible la versión del kernel Linux 4.0

La versión estable del kernel Linux 4.0, apodada como ‘Hurr durr I’m a sheep’ llega a nosotros de la mano de la comunidad a tan solo 2 semanas desde el lanzamiento de la versión 3.19 del kernel de Linux.

La lista de novedades no es demasiado grande. Escribe Linus:

En cuanto a características nuevas, Linux 4.0 no es demasiado especial. La mayoría de cambios están relacionados con la nueva infraestructura para aplicar parches en el kernel; siendo realista hemos hecho muchos más cambios en otras versiones. Esta es una versión para asegurar un buen progreso en el desarrollo de futuras versiones del kernel.

Y es que hay que recordar que tras el lanzamiento de la versión 3.19, Linus Torvalds publicó una encuesta en Google+ donde preguntaba a sus seguidores si querían seguir en la versión 3.x del kernel o dar finalmente el salto como versión 4.0 en la futura compilación y en consecuencia y  con casi 30.000 votos en la encuesta publicada desde el pasado 12 de febrero el 56% de las personas votó por un Linux 4.0 y un 44% para Linux 3.20.

Es decir, la diferencia entre la rama 3.x y la 4.x no es mucha, y el cambio de versión es mas bien implementar un cambio de denominación, de nomenglatura

Entre las mejoras que trae el kernel linx 4.0

  • Mejora el soporte a las nuevas CPU Intel ‘Skylake'(vendrán en la segunda mitad de 2015)
  • Mejora el rendimiento de Linux en PS3
  • Se añade soporte a los System on Chip de Intel Quark
  • Drivers TOpen-source para AMD Radeon con soporte de DisplayPort Audio.
  • Mejoras en drivers HID como los teclados compactos de Lenovo y alguna tableta gráfica Wacom.
  • Ligeros cambios en los sistemas de ficheros F2FS y BtrfFs.

Lo que mas se toma en cuenta de este nuevo kernel, en si no son los cambios, si no la estabilidad, la versión Linux 4.0 del núcleo esté enfocada en la estabilidad y corrección de errores.

Además el que no sea necesario reiniciar el sistema en las actualizaciones del kernel es algo que muchos administradores de sistemas están muy contentos, muy enfocado a todos los que necesiten tener el sistema encendido todo el tiempo, podrán aplicar parches de seguridad -por ejemplo- sin necesidad de reiniciar (apagar el sistema).

.. after extensive statistical analysis of my G+ polling, I’ve come to the inescapable conclusion that internet polls are bad.

Big surprise.

But “Hurr durr I’ma sheep” trounced “I like online polls” by a 62-to-38% margin, in a poll that people weren’t even supposed to participate in. Who can argue with solid numbers like that? 5,796 votes from people who can’t even follow the most basic directions?

In contrast, “v4.0” beat out “v3.20” by a slimmer margin of 56-to-44%, but with a total of 29,110 votes right now.

Now, arguably, that vote spread is only about 3,200 votes, which is less than the almost six thousand votes that the “please ignore” poll got, so it could be considered noise.

But hey, I asked, so I’ll honor the votes.

Linux 4.0 is happening!

fuentes:

https://www.kernel.org/

[fix] geany no inicia, “Attempt to unlock mutex that was not locked”

Hice una actualización, y después de unos días feliz intento abrir el editor geany y cual es mi sorpresa de toparme con el mensaje


toto@linux:~$ geany
Attempt to unlock mutex that was not locked
Abortado

Y pues efectivamente no abría, abortaba el inicio del programa.

corro entonces geany, dándole la instrucción geany -v, para leer el mensaje de donde podría estar el error, y veo que se detiene al momento de invocar los plugins


toto@sidux:~$ geany -v
Geany-INFO: Geany 1.24.1, es_MX.UTF-8
Geany-INFO: GTK 2.24.25, GLib 2.42.0
Geany-INFO: System data dir: /usr/share/geany
Geany-INFO: User config dir: /home/toto/.config/geany
Geany-INFO: System plugin path: /usr/lib/i386-linux-gnu/geany
Geany-INFO: Added filetype Go (58).
Geany-INFO: Added filetype Clojure (59).
Geany-INFO: Added filetype Genie (60).
Geany-INFO: Added filetype Scala (61).
Geany-INFO: Added filetype Cython (62).
Geany-INFO: Added filetype CUDA (63).
Geany-INFO: Added filetype Graphviz (64).
Geany-INFO: Loaded: /usr/lib/i386-linux-gnu/geany/autoclose.so (Autocierre)
Geany-INFO: Loaded: /usr/lib/i386-linux-gnu/geany/addons.so (Añadidos)
Geany-INFO: Loaded: /usr/lib/i386-linux-gnu/geany/defineformat.so (Definir formateador)
Attempt to unlock mutex that was not locked
Abortado

hago una prueba de llamar a geany, sin plugins, con la instrucción geany -p y abre perfectamente

toto@sidux:~$ geany -p

por lo que voy a ver (editar) el archivo ~/.config/geany/geany.conf para ver cuales plugins están activos y cual es él que esta dando problemas.

Solución

Después de probar quitando uno por uno, veo que es debugger.so el que da problemas, por lo cual borro de la lista, guardo, inicio geany y todo funciona bien nuevamente

la linea editada en la sección plugins, listado en active_plugins= quedo así después de borrar /usr/lib/i386-linux-gnu/geany/debugger.so; (efectivamente, tengo activados muchos plugins)


[plugins]
load_plugins=true
custom_plugin_path=
active_plugins=/usr/lib/i386-linux-gnu/geany/autoclose.so;/usr/lib/i386-linux-gnu/geany/addons.so;/usr/lib/i386-linux-gnu/geany/defineformat.so;/usr/lib/i386-linux-gnu/geany/geanypy.so;/usr/li
b/i386-linux-gnu/geany/geanymacro.so;/usr/lib/i386-linux-gnu/geany/multiterm.so;/usr/lib/i386-linux-gnu/geany/filebrowser.so;